Service disruption: myrdp.download portal and cas.itopia.com
Incident Report for itopia
Resolved
The Issues affecting myrdp.download and cas.itopia.com have been fully resolved and all services are working as normal. We apologize for any inconvenience this may have caused.
Posted Nov 16, 2020 - 11:31 EST
Monitoring
The issues affecting myrdp.download and cas.itopia.com have been resolved. We keep monitoring the performance to ensure the full recovery of our services.
Posted Nov 16, 2020 - 11:22 EST
Investigating
We are currently experiencing service disruption due to Firebase Hosting connectivity issues.

Your GCP resources including the end-user login to their cloud desktops remain unaffected.

We will provide further updates as soon as they become available.
Posted Nov 16, 2020 - 11:04 EST
This incident affected: Main Portal and RDP Download Portal.