Trouble logging in
Incident Report for itopia
Resolved
This incident has been resolved.
Posted Jul 02, 2018 - 20:24 EDT
Monitoring
The portal is now operational; however, we'll continue to monitor and provide regular updates.

The issue has been identified and a fix is being implemented.
Posted Jul 02, 2018 - 14:34 EDT
Investigating
We are still experiencing a service disruption for cas.itopia.com.

Our team is working to identify the cause and implement a solution.

We will send an additional update in 30 minutes. We apologize for the inconvenience.
Posted Jul 02, 2018 - 13:50 EDT
This incident affected: Main Portal.