Service disruption: myrdp.download portal and Google authentication
Incident Report for itopia
Resolved
Issues affecting myrdp.download portal and Google authentication to cas.itopia.com have been fully resolved and all services are working as normal.
We apologize for any inconvenience this may have caused.
Posted Sep 04, 2019 - 13:28 EDT
Monitoring
The issues with Google authentication and myrdp.download portal have been resolved. We keep monitoring the performance to ensure full recovery of our services.
Posted Sep 04, 2019 - 12:01 EDT
Update
We are continuing to investigate this issue.
Posted Sep 04, 2019 - 11:34 EDT
Investigating
We are currently experiencing a service disruption affecting myrdp.download portal and Google authentication to cas.itopia.com. You may experience login issues when using "Sign in with Google" option and accessing myrdp.download portal.

Our software team is working to identify the root cause and implement a solution.

We will send an additional update in 30 minutes.
Posted Sep 04, 2019 - 11:33 EDT
This incident affected: Main Portal and RDP Download Portal.